SharePoint 2010 or SharePoint 2013 or SharePoint Online.